Bluetooth Module

Ask questions and get answers if you hit a snug or unsure how to set up your ride
Talon
Posts: 11
Joined: Sun Apr 14, 2019 5:11 pm
Location: SE Michigan

Bluetooth Module

Unread post by Talon » Sat Apr 20, 2019 10:02 am

I just got your newest dual mode 12F controller last week. Can I just disconnect the Bluetooth module after I programed the controller and just hook up my CA V2 for monitoring? Sometimes I do not want my phone mounted on my handle bar.
Owning and maintaining the undisputed "Fastest URB-E in the USA"....12F PV Controller, 52 volt, 10" Hub-Motor :D

PVadmin
Site Admin
Posts: 23
Joined: Sat Feb 09, 2019 5:55 pm

Re: Bluetooth Module

Unread post by PVadmin » Wed Apr 24, 2019 5:16 pm

Yes, you can do that or build a splitter and run them both at the same time.

Talon
Posts: 11
Joined: Sun Apr 14, 2019 5:11 pm
Location: SE Michigan

Re: Bluetooth Module

Unread post by Talon » Mon May 13, 2019 2:47 pm

I installed my PV 12fet controller today. I cannot get the software on my android phone to find the Bluetooth module. It just says "looking for Bluetooth". All connections are double checked and nothing is incorrect. The controller powers my bike OK, it is just that I cannot change any of my settings or view the on screen app while driving that I paid for. I think the Bluetooth module is defective ☹️ Any ideas?
Owning and maintaining the undisputed "Fastest URB-E in the USA"....12F PV Controller, 52 volt, 10" Hub-Motor :D

PVadmin
Site Admin
Posts: 23
Joined: Sat Feb 09, 2019 5:55 pm

Re: Bluetooth Module

Unread post by PVadmin » Tue May 14, 2019 9:37 am

Please double check it's connected correctly per this manual:
http://powervelocity.com/blog/bluetooth-module/

Please also read this to make sure you are connecting correctly:
http://powervelocity.com/blog/bluetooth-module/
Talon wrote:
Mon May 13, 2019 2:47 pm
I installed my PV 12fet controller today. I cannot get the software on my android phone to find the Bluetooth module. It just says "looking for Bluetooth". All connections are double checked and nothing is incorrect. The controller powers my bike OK, it is just that I cannot change any of my settings or view the on screen app while driving that I paid for. I think the Bluetooth module is defective ☹️ Any ideas?

Talon
Posts: 11
Joined: Sun Apr 14, 2019 5:11 pm
Location: SE Michigan

Re: Bluetooth Module

Unread post by Talon » Tue May 14, 2019 11:30 am

Yes I checked both Bluetooth and Hall, and Phase connections 5 times and everything is correct. I only have the 52 volt battery, Hall, Phase, and throttle connected directly to the Bluetooth module. I do not use any of the other features and wires for my URB-E. The bike runs well on whatever default settings that you programmed into the controller when you shipped it to me. I need to be able to Program my own settings, plus be able to view the dashboard on my LG V20 android phone. Right now the PV software just says "looking for Bluetooth connection". I have even removed the PV app from my phone and reloaded it from the Android Playstore and still get nothing.
Owning and maintaining the undisputed "Fastest URB-E in the USA"....12F PV Controller, 52 volt, 10" Hub-Motor :D

PVadmin
Site Admin
Posts: 23
Joined: Sat Feb 09, 2019 5:55 pm

Re: Bluetooth Module

Unread post by PVadmin » Tue May 14, 2019 3:46 pm

OK, first thing first. Can you see "PowerVeloCity-I" when you hit Connect button under Settings or when you go to Android BT scanner?

Talon wrote:
Tue May 14, 2019 11:30 am
Yes I checked both Bluetooth and Hall, and Phase connections 5 times and everything is correct. I only have the 52 volt battery, Hall, Phase, and throttle connected directly to the Bluetooth module. I do not use any of the other features and wires for my URB-E. The bike runs well on whatever default settings that you programmed into the controller when you shipped it to me. I need to be able to Program my own settings, plus be able to view the dashboard on my LG V20 android phone. Right now the PV software just says "looking for Bluetooth connection". I have even removed the PV app from my phone and reloaded it from the Android Playstore and still get nothing.

Talon
Posts: 11
Joined: Sun Apr 14, 2019 5:11 pm
Location: SE Michigan

Re: Bluetooth Module

Unread post by Talon » Tue May 14, 2019 4:13 pm

No mine says it is PowerVelolocity-A for Android. It says this because it is "paired" with it. Remember that I do have a 6FET controller that I bought off you 2 years ago. When I push the "connect button" in settings the screen says PowerVeloCity scanner then after about 2 minutes the screen goes blank. It is unable to find the Bluetooth module. I have Android 8.0 on my phone and no blinking light under the shrink wrap of the module.
Owning and maintaining the undisputed "Fastest URB-E in the USA"....12F PV Controller, 52 volt, 10" Hub-Motor :D

PVadmin
Site Admin
Posts: 23
Joined: Sat Feb 09, 2019 5:55 pm

Re: Bluetooth Module

Unread post by PVadmin » Wed May 15, 2019 5:23 am

Please unpair and scan for new devices while the controller is on and the BT is plugged in.
Also, please go to phone BT settings and clear BT cache and restart the phone.
After restart, don't pair the BT, go straight into the app Settings - Connect and connect to "PowerVeloCity-i".
Talon wrote:
Tue May 14, 2019 4:13 pm
No mine says it is PowerVelolocity-A for Android. It says this because it is "paired" with it. Remember that I do have a 6FET controller that I bought off you 2 years ago. When I push the "connect button" in settings the screen says PowerVeloCity scanner then after about 2 minutes the screen goes blank. It is unable to find the Bluetooth module. I have Android 8.0 on my phone and no blinking light under the shrink wrap of the module.

Talon
Posts: 11
Joined: Sun Apr 14, 2019 5:11 pm
Location: SE Michigan

Re: Bluetooth Module

Unread post by Talon » Wed May 15, 2019 8:29 am

OK..... I unpaired "PowerVeloCity A" and searched with Bluetooth turned on with my phone. I cleared the app cache. I found "Android I" and pushed it. The LED lights on the Bluetooth Module are now on. I push the "connect" button in the settings of the PV app on my phone and the LED lights on the module start flashing then nothing. The phone app never finds the module and continues to flash the LED lights constantly.
Owning and maintaining the undisputed "Fastest URB-E in the USA"....12F PV Controller, 52 volt, 10" Hub-Motor :D

PVadmin
Site Admin
Posts: 23
Joined: Sat Feb 09, 2019 5:55 pm

Re: Bluetooth Module

Unread post by PVadmin » Wed May 15, 2019 11:38 am

Oh, I reread your previous messages and realized I missed one important detail. This module is from 2 years ago.
Is the module internal or external?
Talon wrote:
Wed May 15, 2019 8:29 am
OK..... I unpaired "PowerVeloCity A" and searched with Bluetooth turned on with my phone. I cleared the app cache. I found "Android I" and pushed it. The LED lights on the Bluetooth Module are now on. I push the "connect" button in the settings of the PV app on my phone and the LED lights on the module start flashing then nothing. The phone app never finds the module and continues to flash the LED lights constantly.

Post Reply